Cisco Site to Site GRE VPN Tunnel with EIGRP

Cisco Site to Site GRE VPN Tunnel with EIGRP

What is a GRE tunnel?

Generic Routing Encapsulation (GRE) is a tunneling protocol that lets you run a routing protocol between endpoints.

This example will create a GRE tunnel between two routers and will run EIGRP between the two.

Topology Summary:

  • 192.168.13.0/24 will be the Tunnel Network IP block
  • ┬áRouter-1
    • lo0 10.1.1.0/24
    • e0/0 192.1.12.2
  • Router-2
    • lo0 10.2.2.0/24
    • e0/0 192.1.23.2

Router-1

  • interface tunnel1
    • ip address 192.168.13.1 255.255.255.0
    • tunnel source 192.1.12.1
    • tunnel destination 192.1.23.3
  • router eigrp 100
    • no auto-summ
    • net 192.168.13.0
    • net 10.0.0.0

Router-2

  • interface tunnel1
    • ip address 192.168.13.3 255.255.255.0
    • tunnel source eth0/0
    • tunnel destination 192.1.12.1
  • router eigrp 100
    • no auto-summ
    • net 192.168.13.0
    • net 10.0.0.0

 

Leave a Reply

Your email address will not be published. Required fields are marked *